Embraceware Blog. Communicate with Us

HoloSnaps • Support


What are the device requirements?

Any iPhone or iPod touch capable of running iOS 3.1.3 or later.


Which languages are supported?

HoloSnaps is available in English, Arabic, Czech, Dutch, Finnish, French, German, Italian, Japanese, Korean, Portuguese, Russian, Simplified Chinese, Spanish, Swedish.


Helpful Links

Leave a comment