Embraceware Blog. Communicate with Us

Awaken • Support


What are the device requirements?

Awaken for iOS is compatible with any iPhone, iPad or iPod touch capable of running iOS 4.3 or later.

Awaken for macOS is compatible with any Mac capable of running macOS 10.8 or later.


Which languages are supported?

Awaken for iOS is available in English, Dutch, French, German, Japanese, Simplified Chinese, Spanish and Swedish.

Awaken for macOS is available in English, French, German, Japanese and Simplified Chinese.


Helpful Links

Leave a comment